Announcement

Collapse
No announcement yet.

What Is Wrong With This Accelerator Pump?

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • YellowRose
    Super-Experienced


    • Jan 21 2008
    • 17295

    What Is Wrong With This Accelerator Pump?

    I received the following from Tom Taylor ~ scumdog from "The Land Of The Long White Cloud". (New Zealand ~ Goggle that statement and look at the Cloud images...

    "Hi Ray, Hopefully you’re still well and the days are getting warmer? Found these old photos of mine and thought it would be good for a laugh on Anything Goes!

    I thought if you posted the pic with the comment “who can see what is wrong with this accelerator pump” and see who is first to comment, (it’s the bottom pic on my screen.) It’s on the carb on the 390 in my ‘66 Thunderbird, I had it apart to correct an issue and reassembled it incorrectly. Hopefully this makes sense, stay safe and regards from New Zealand, Tom."

    Here are the two pix he sent. I did not receive them top and bottom, but left and right...
    You do not have permission to view this gallery.
    This gallery has 2 photos.

    Ray Clark - Squarebirds Administrator
    The Terminator..... VTCI #11178 ITC #6000 Yellow Mustang Registry (YMR) #12188
    Contact me via Private Message for my email address, or Call (Cell) 210-875-1411

    https://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm
    Faye's Ovarian Cancer Memorial Website.
    https://faye.rayclark.info/index.html
  • jopizz
    Super-Experienced


    • Nov 23 2009
    • 8460

    #2
    The picture on the right is what happens when you install the cover upside down. The round bump is what pushes the accelerator pump in and needs to be on the inside.

    John
    John Pizzi - Squarebirds Administrator

    Thunderbird Registry #36223
    jopizz@squarebirds.org 856-779-9695

    https://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

    Comment

    • scumdog
      Super-Experienced

      • May 12 2006
      • 1528

      #3
      Originally posted by jopizz
      The picture on the right is what happens when you install the cover upside down. The round bump is what pushes the accelerator pump in and needs to be on the inside.

      John
      Well done John, nothing gets past YOU!
      I never noticed the pump cover was upside down and wondered why the car would run but ‘bogged’ when I opened the throttle suddenly, it took a minute or two before ‘the penny dropped’ and I realized what the problem was!
      A Thunderbirder from the Land of the Long White Cloud.

      Comment

      Working...
      😀
      🥰
      🤢
      😎
      😡
      👍
      👎