Announcement

Collapse
No announcement yet.

Carb leak

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Flooding is caused either by a worn or sticking needle valve or too high a float level. A new needle valve and adjusting the float height per the shop manual should fix that problem. Usually flooding will cause poor running, stalling and hard starting. If your car was running well I doubt it was flooding. I would still suspect a worn throttle shaft.

    John
    John Pizzi - Squarebirds Administrator

    Thunderbird Registry #36223
    jopizz@squarebirds.org 856-779-9695

    https://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

    Comment


    • #32
      I have seen nothing wrong on the shafts, maybe the car was not running so good. Or problem was just marginal. Or both.

      As for the extra spring, I found a picture I missed until now where it is shown installed on the pump's cup ! So it's been used as a return spring in place of #24 !?
      Problem is the pump down movement is now limited by the spring thickness and the cup does not go down as much (by .050"). Is that bearable?


      As for the ball in the diaphragm, Mike said "Yes, if your secondary diaphragm housing has the hole as illustrated in our video, the ball and retainer does need to be in place, otherwise you just have an open port to the atmosphere and you won't get any vacuum."

      But on Ford's manual "A ball check, located in the vacuum passage restricts the amount of venturi vacuum entering the diaphragm chamber." I am not sure it's open to the atmosphere.

      Bleeder screen is also missing on that carburetor. This part is not available, what does it filter? Can I have it made in some kind of mesh?

      20200729_184052.jpg

      Comment


      • #33
        If the spring was on the plunger when you took it apart I would use it. The plunger's job is to push fuel out, it's not necessary for it to bottom out. As for the check ball put a thin wire through the hole and see if it's open. I don't see any bleeder screen on the diagrams, just the washer.

        John
        John Pizzi - Squarebirds Administrator

        Thunderbird Registry #36223
        jopizz@squarebirds.org 856-779-9695

        https://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

        Comment


        • #34
          Bleeder screen is not always on diagrams but saw it on a disassembling procedure.
          Yes I will use this spring. Hope it's not the culprit for the problems I had !
          As for the ball Mike said "Some use a check ball in the secondary, some do not, which is why you're not seeing it in the diagram. If you didn't have a ball in there when you took it apart don't use it. If you did, then put it back in."
          So I will put everything back together as it was. I hope the cleaning and new parts will help with this leak.
          I still have to wait for a few more days now as the choke mecanism has been in a slow rust eating solution for a week and I assume 1 more week is needed.

          The choke piston has 2 grooves. I saw no mention of an O-ring in those grooves. They were full of black compound. Not sure if that was remnants of O-rings or just debris...

          Comment


          • #35
            Carburetor is now installed, car running but secondary throttles are not opening.
            What can it be?
            I remind you it had a new diaphragm but I hadn't a ball check in the diaphragm and did not replaced it as it was not in the kit.

            Comment


            • #36
              How far did you open the throttle with the car running? The secondary only begins to open at moderate to full throttle.

              John
              John Pizzi - Squarebirds Administrator

              Thunderbird Registry #36223
              jopizz@squarebirds.org 856-779-9695

              https://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

              Comment


              • #37
                I pulled it in full but not for long ...
                Also engine vacuum reads at around 20

                Comment


                • #38
                  I would go over the parts diagram again and make sure you installed everything correctly and didn't forget anything. If it didn't have any check ball before you took it apart and it worked then it shouldn't need one now.

                  John
                  John Pizzi - Squarebirds Administrator

                  Thunderbird Registry #36223
                  jopizz@squarebirds.org 856-779-9695

                  https://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

                  Comment


                  • #39
                    Well I did not checked before if 2nd throttle opens or not and now the car seems to performs about the same as before.

                    Comment


                    • #40
                      I have just been told that secondary throttles opens only when engine is on load and can not open on neutral.
                      Even though I don't understand why this could be, it would explain it...

                      Comment

                      Working...
                      X