This will take you to the main site where there is history, technical information and other information on these cars.
This takes you back to the main page of the forums.
This is the control panel to change your password, information and preferences on this message board.
Click here if your lost your password or need to register on this message board. You must be a registered user to post. Registration is free.
Search this board for information you need.
Click here to buy cool Squarebirds mechandise.
Click here to support Squarebirds.org. For $20 annually receive 20mBytes webspace, a Squarebirds e-mail address and member's icon on the message board.
Prev Previous Post   Next Post Next
  #1  
Old 04-10-2012, 10:21 PM
Woodfin Woodfin is offline
Newbie
 
Join Date: Apr 8 2012
Posts: 7
Woodfin is on a distinguished road
Default Restoration Questions

Brand new SquareBird owner here.
I just picked it up this weekend and have spent the past few days poking and prodding the entire car looking for rust and trouble spots. I found some that I expected and some I did not. I've never done any restoration work before and I'm going to be restoring the car with my sons. It was running when it was parked in a barn of the prior owner in 1993. It's not moved or been started since then. I'm going to have a mechanic friend look at the motor.

We'll learn the ins and outs as we go, but I hate to make stupid mistakes and dont mind asking questions when I dont know how to do something.

That said, I do have a few questions. I found the expected rust on the rockers, trunk spare tire well and a few other spots, but found a lot of rot around the bottom of the radiator. It looks like the support bar going across the bottom is almost completely gone along with the battery holder. Is this common ?
I wanted to take out the radiator to get a good look. I took off the top support, but on the bottom there was very little left.

The radiator was full and I did not see any leaks, but the bottom looked like there was nothing left. There are two of the bolts on the bottom were rusted through and the third broke with just a little pressure. I took the rad out and was thinking it was junk, but read a few posts that indicated I should look at having the radiator fixed. Is this something anyone has experienced ?

Thanks in advance

Rich
Reply With Quote
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:16 AM.

Driving, racing or working on cars can be hazardous. The procedures and advice on this website including the message board are opinion only. Squarebirds.org and its webmasters and contributors do not guarantee the correctness of the advice and procedures. The Squarebirds.org and its webmasters assume no liability for any damage, fines, punishment, injury or death resulting from following these procedures or advice. If you do not have the skills or tools to repair your car, please consult a professional. By using this site you agree to hold harmless the Squarebirds.org, its authors and its webmasters from any resulting claim and costs that may occur from using the information found on this site.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Any submissions to this site and any post on this site becomes property of Squarebirds.org . The webmasters reserve the right to edit and modify any submissions to this site. All material on this is site is copyrighted by the Squarebirds.org. Reproduction by any means other than for personal use is strictly prohibited. Permission to use material on this site can be obtained by contacting the webmasters. Copyright 2002-2016 by Squarebirds.org.