View Single Post
  #10  
Old 11-26-2014, 12:35 AM
toddgilroy toddgilroy is offline
Experienced
 
Join Date: Aug 30 2014
Posts: 171
toddgilroy is on a distinguished road
Default

Resurrecting an old thread due to some questions re: connections to the window relay. I have a 60 convertible with power windows and driver seat. After getting a new dash wiring harness in, finished the rest of the connections per wiring diagrams and the Electrical Assembly Manual.

I now have brake lights and power to the conv top, (little victories ), and have power to the seat and windows, but just get clicks in the window relay and the top switch control relay when I try to start the car. I do have the conv top connected to the neutral safety switch with a jumper to the neutral safety switch wire, so I don't think that is the issue.

First picture is my new wiring...One thing that seems odd is I had to use a little jumper from the 30A circuit breaker on the front of the window relay over to the right side to get power to the windows...is that a sign the relay is bad (or bad connection)?

Second picture is prior owner setup. Prior to rewiring, the car started, had power to the seats and windows, but not the top. Also, the prior owner did not have either circuit breaker installed, just appeared to bypass the relay.

Thanks!
Attached Images
File Type: jpg IMG_2469.JPG (95.7 KB, 99 views)
File Type: jpg IMG_2152.JPG (110.7 KB, 99 views)
__________________
Todd Gilroy
1960 Tbird Convertible
Thunderbird Registry #54651
Reply With Quote