View Single Post
  #7  
Old 02-20-2011, 10:01 PM
villain villain is offline
Apprentice
 
Join Date: Jan 23 2011
Posts: 60
villain is on a distinguished road
Default

So I got it home finally and put 25-30 miles on it right away. There are a variety of issues, but the first question I got (I have been swapping emails with Ray on the subject) is what the heck do you do for gas for the thing? I assume it wants leaded fuel? I probably already messed stuff up cause i put 12 gal or so of Premium Unleaded in it right away before cruising around a bit.
I expect to have to rebuild the engine anyway as I have little to no documentation about it's history, but still I don't want to mess anything up.
Any advice is welcome and appreciated.
And in addition to needing some interior fixing up and a full paint job that I assume will be a good 10-12k so far I need to address (should i cross-post on the technical forum?):
  • It only starts in Neutral (and neutral is a bit off of where it should be visually)
  • The wipers dont work
  • The turn signals dont work (and I hear or read somewhere you can mod it with the sequential ones across the 3 lights in the rear?) - also i dont think they are working in the front or the rear (not sure where the front signals are exactly...but i dont see them blink) so maybe that means it's the switch in the column?
  • The horn doesn't work
  • The radio doesn't work (although i just want it to look right/oem and be able to play an ipod really)
  • The clock doesn't work
  • both my driver and passenger side windows are cracked and will need to be replaced
  • I will definitely want to swap it to disc brakes (can you do all 4 corners? or just the front?)
  • I will want a new steering wheel - i hate the stuff currently wrapped on it and think the white underneath is chipped and cracked
  • There is some interior trim that should be replaced and the seat covers too probably based on a tear in the driver back side
  • It seemed to smoke a bit from the defrosters and from the passenger footwell/floorboard at first, but that seems to have gone away? not sure if that's normal or what it was even. There was some antifreeze it looked like on the passenger rubber floormat too when i first got it, but doesnt look like any more has dripped there or anything - but where would that even come from?
So first i want to have it gone through and make sure the engine is sorted and all the electrical stuff is addressed and hopefully get the brakes upgraded right away...and figure out how i need to fuel the thing :-)
Then I can worry about the cosmetic stuff and get it painted and all that.

I gotta say though, I really LOVE the car. It's night and day from anything else I have ever owned and it's a blast to cruise around in.
__________________
-- D_Villain
- 1960 Thunderbird J-code Golde (Registry #1560)
Reply With Quote