Squarebirds, Rocketbirds, and Fifties/Sixties Ford Discussion Forum

Squarebirds, Rocketbirds, and Fifties/Sixties Ford Discussion Forum (http://squarebirds.org/vbulletin/index.php)
-   1964 To 1966 Flairbirds - General Technical Discussion (http://squarebirds.org/vbulletin/forumdisplay.php?f=26)
-   -   electrical puzzle (http://squarebirds.org/vbulletin/showthread.php?t=22028)

Larry Tappen 09-30-2017 03:09 PM

electrical puzzle
 
hi everyone, maybe someone can help me out. my 64 bird has a gremlin, meaning everything electrical will operate even with the key is off or on or in acc. mode. such as heater motor,window washer pump, power windows. where should I look first to try to solve this problem? I've checked as best I could with elec. books I bought. thanks for any and all help, larry.

jopizz 09-30-2017 03:17 PM

Everything goes through the ignition switch so check there first. If that's ok then check the connector block on the driver side firewall where the wires go through. That's been known to cause multiple problems.

John

simplyconnected 09-30-2017 07:08 PM

I'm with John. You have a bad key switch.

Larry Tappen 09-30-2017 08:47 PM

electrical puzzle
 
gentlemen, I checked the wire plug and ignition switch as john suggested, can't find anything wrong visual wrong. maybe the switch is bad inturnaly? switch seems to be fine starting the car, I don't want to buy one if not needed. thanks guys, larry.:(

jopizz 09-30-2017 09:08 PM

Quote:

Originally Posted by Larry Tappen (Post 111383)
gentlemen, I checked the wire plug and ignition switch as john suggested, can't find anything wrong visual wrong. maybe the switch is bad inturnaly? switch seems to be fine starting the car, I don't want to buy one if not needed. thanks guys, larry.:(

Check it using an ohmmeter going from the BAT terminal to the other terminals with the key in the off position. If there's continuity to any of the other terminals then it's shorted internally. If it tests ok then it's in the wiring. Are you sure you don't have something wired wrong at the fuse box. Try removing the blk-green wire that's on the ring terminal of the ignition switch and see if it fixes it.

John


All times are GMT -4. The time now is 04:35 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Any submissions to this site and any post on this site becomes property of Squarebirds.org . The webmasters reserve the right to edit and modify any submissions to this site. All material on this is site is copyrighted by the Squarebirds.org. Reproduction by any means other than for personal use is strictly prohibited. Permission to use material on this site can be obtained by contacting the webmasters. Copyright 2002-2016 by Squarebirds.org.