Squarebirds, Rocketbirds, and Fifties/Sixties Ford Discussion Forum

Squarebirds, Rocketbirds, and Fifties/Sixties Ford Discussion Forum (http://squarebirds.org/vbulletin/index.php)
-   Golde Top (Sunroof) Forum (http://squarebirds.org/vbulletin/forumdisplay.php?f=20)
-   -   My new j-code golde (http://squarebirds.org/vbulletin/showthread.php?t=10575)

YellowRose 02-21-2011 01:37 AM

My new j-code golde Reload this Page Reply to Thread
 
First of all, let me say that I have not heard of a plate below the AC controls other than the long, rectangular one that says "AIR COND PULL HEATER". Maybe that is the one that you are talking about. If so, Bob, at Bobs Birdhouse in Delaware, Don and the guys at the Bird Nest in Oregon, and maybe Carl ~ partsetal here on the Forum might have one off his parts cars. PM him first.

Now let me see if I can help you with some of the things you are seeing that needs to be fixed.
  • It only starts in Neutral (and neutral is a bit off of where it should be visually)
Try putting it over into Park and pull the gear shift lever towards you to see if it will start there. This might be a matter of adjusting the steering linkage, or the Neutral Switch which is down at the bottom of the steering column, as I recall. Others can set you straight on this.
  • The wipers dont work
The wipers never worked that great at all since they are vacuum wipers. But you should be seeing some action out of them when you turn them on. This could be a matter of the vacuum hoses not being hooked up to the windshield wiper motor which is behind the glove box. Or it could be an electrical problem with the windshield wiper motor not getting any juice to it. Or something else. If that car still has the original fuel pump on it, there should be a hose coming off the top of the fuel pump, which is the vacuum pump. One hose goes to the manifold and the other across over to a hole in the firewall to the wiper motor. Me, I got tired of putting up with a vacuum motor and had an electric one installed. You can read about that on the Technical Resource Library link. In fact, you should bring that up (all of you!) and bookmark it because many of the things that are talked about in these threads on the Forum, are already covered there.
  • The turn signals dont work (and I hear or read somewhere you can mod it with the sequential ones across the 3 lights in the rear?) - also i dont think they are working in the front or the rear (not sure where the front signals are exactly...but i dont see them blink) so maybe that means it's the switch in the column?
The turn signals not working could be in the steering column with that mechanism, or it could be electrical. You should see the turn signal indicators blinking when you push the blinker shaft down or up. You could have a problem with you light switch under the dash. Bulbs could be blown. Your front blinkers are built into the bumpers. Yes, there is the mod that you can do to a '60 that, like the Flairbirds, will sequence your tail lights when you turn, which is cool. It is also in the TRL.
  • The horn doesn't work
Once again, this could be in the steering wheel, with the horn contacts not making contact. It could also be electrical, with the power not getting to the horns (two of them, left and right) in the grill.
  • The radio doesn't work (although i just want it to look right/oem and be able to play an ipod really)
There is a power supply/amplifier unit on the left side of the steering wheel behind the cover in front of your left knee. That could be out and the diodes are impossible to find. Finding a working unit is difficult. I happen to have a spare radio and spare power supply/amplifier that works. Since you would like it to look like the original one, there are a number of guys who specialize modifying that radio for AM/FM/Cassette, maybe even CD's, and you can play your Ipod through it, as I recall. It will have the Tbird face plate on it, but inside that box will be a new, modern radio. Once again, this is covered in the TRL under Radio.
  • The clock doesn't work
There are procedures in the TRL for repairing your clock. Or... you can do what I did... Send it to the Birds Nest and have them fix it and quartz it for you. It was worth it to me.
  • both my driver and passenger side windows are cracked and will need to be replaced
Carl ~ partsetal here, might be able to help you with that. Or any of the Tbird parts houses. Or some of the guys that are parting out Squarebirds that are listed in the For Sale/Parts Forum below.
  • I will definitely want to swap it to disc brakes (can you do all 4 corners? or just the front?)
You can do all four corners and there are those that have. I would talk with Dave Dare ~ simplyconnected and Howard Prout up in Canada, who recently did his. There are also others on here who have been this route.
  • I will want a new steering wheel - i hate the stuff currently wrapped on it and think the white underneath is chipped and cracked
The man to see about getting your steering wheel done is Jed Zimmerman, Ca58Tbird here on the Forum. He is the only one, that I know of, who repairs them. It will look like it just came from the factory when he finishes it. Mine was redone by Jed, as are others on here. Look down in the Advertisers Forum, for his contact information. He is also the only one that makes the seat foams for all '58-'66 Tbirds for the parts vendors.
  • There is some interior trim that should be replaced and the seat covers too probably based on a tear in the driver back side
As we have discussed, you need to find a good interior man for this work that really knows his stuff. You can get the seat covers and door panels from any of the vendors.
  • It seemed to smoke a bit from the defrosters and from the passenger footwell/floorboard at first, but that seems to have gone away? not sure if that's normal or what it was even. There was some antifreeze it looked like on the passenger rubber floormat too when i first got it, but doesnt look like any more has dripped there or anything - but where would that even come from?
What you saw might be because the car has not been driven much recently, I assume. But the techies on here can tell you more about that, I hope.

So first i want to have it gone through and make sure the engine is sorted and all the electrical stuff is addressed and hopefully get the brakes upgraded right away...and figure out how i need to fuel the thing :-)
Then I can worry about the cosmetic stuff and get it painted and all that.

I gotta say though, I really LOVE the car. It's night and day from anything else I have ever owned and it's a blast to cruise around in. _
_________________

Richard D. Hord 02-21-2011 09:30 AM

Quote:

Originally Posted by villain (Post 53239)
So I got it home finally and put 25-30 miles on it right away. There are a variety of issues, but the first question I got (I have been swapping emails with Ray on the subject) is what the heck do you do for gas for the thing? I assume it wants leaded fuel? I probably already messed stuff up cause i put 12 gal or so of Premium Unleaded in it right away before cruising around a bit.
I expect to have to rebuild the engine anyway as I have little to no documentation about it's history, but still I don't want to mess anything up.
Any advice is welcome and appreciated.
And in addition to needing some interior fixing up and a full paint job that I assume will be a good 10-12k so far I need to address (should i cross-post on the technical forum?):
  • It only starts in Neutral (and neutral is a bit off of where it should be visually)
  • The wipers dont work
  • The turn signals dont work (and I hear or read somewhere you can mod it with the sequential ones across the 3 lights in the rear?) - also i dont think they are working in the front or the rear (not sure where the front signals are exactly...but i dont see them blink) so maybe that means it's the switch in the column?
  • The horn doesn't work
  • The radio doesn't work (although i just want it to look right/oem and be able to play an ipod really)
  • The clock doesn't work
  • both my driver and passenger side windows are cracked and will need to be replaced
  • I will definitely want to swap it to disc brakes (can you do all 4 corners? or just the front?)
  • I will want a new steering wheel - i hate the stuff currently wrapped on it and think the white underneath is chipped and cracked
  • There is some interior trim that should be replaced and the seat covers too probably based on a tear in the driver back side
  • It seemed to smoke a bit from the defrosters and from the passenger footwell/floorboard at first, but that seems to have gone away? not sure if that's normal or what it was even. There was some antifreeze it looked like on the passenger rubber floormat too when i first got it, but doesnt look like any more has dripped there or anything - but where would that even come from?
So first i want to have it gone through and make sure the engine is sorted and all the electrical stuff is addressed and hopefully get the brakes upgraded right away...and figure out how i need to fuel the thing :-)
Then I can worry about the cosmetic stuff and get it painted and all that.

I gotta say though, I really LOVE the car. It's night and day from anything else I have ever owned and it's a blast to cruise around in.

Hey David,
Welcome to the ownership of a classic car:) You named her yet?
Richard D. Hord

tbird430 02-21-2011 01:00 PM

Nice Bird, and congrats on the original dealer broucher & ROT sheet!! :cool:

- I think adjusting the neutral safety switch might fix your 1st problem. I would also purchase a new shift detent plate & shift lever.

-I would forget the stock vaccum wiper system and purchase one of these new electric wiper kits. They bolt right into place of the original, you just need the knob extenion kit to use the stock white dash knob.

- I would send your stock AM radio off for the AM/FM conversion with RCA output jacks and stereo sound. That way the dash is uncut & still lokks OE.

-Remove your clock and send it off for a quartz conversion. This way it never stops ticking & looks factory correct too.

-Yes, you can convert to 4-whl disc brakes, It only costs money. :D

-I would get with one of our members on here, Jed Zimmerman (Ca58tbird). He makes replacement seat foam kits and offers a fantastic steering wheel restoration service too.

-I would order any needed trim (door panels, carpet, seat covers) from Concours Parts & Accy's. They are a great T-Bird parts vendor. Here's a link: http://www.concoursparts.com/

-You will need a new heater core & seal to correct your right floorboard leak. (Concours Parts will have this too).

- I don't know about that A/C dash plate. Maybe ask someone at Concours or try another member on here, Carl Heller (partsetal). I bet you can find a good original "donor" with a few phone calls.

vernz 02-22-2011 09:27 AM

Don't give up on your original radio too quickly. I thought mine didn't work for about 6 months then turned it on and inadvertently left it on for a while. Suddenly I had sound. Turns out that I had forgotten how long it takes the radio tubes to warm up start working.

Vern

villain 02-22-2011 02:18 PM

Quote:

Originally Posted by vernz (Post 53296)
Don't give up on your original radio too quickly. I thought mine didn't work for about 6 months then turned it on and inadvertently left it on for a while. Suddenly I had sound. Turns out that I had forgotten how long it takes the radio tubes to warm up start working.

Vern

haha, well...there is something coming through the speakers somehow (i have been leaving it on), cause with it on and my cell phone in the car, I can get that interference noise from the phone through the speakers. I moved the dial around and can't seem to pick anything up though, so who knows.

But regardless, I doubt that original one will pipe a usb through it really easily, so I may have to go with one of the aftermarket options that still looks oem.

villain 02-22-2011 02:27 PM

Thanks for all the help already guys.
I found a good restoration place that I went and talked to yesterday - http://realhotrods.com/index.asp
they are all about the project and I gave them my list last night as well as recommended some of the pointers you guys have already given me. They actually knew the car well and are apparently good friends with Fritz Wilson who ran the 59 in Nascar and lives up in Loveland Colorado.
They seem to stay pretty busy, but I'll get in there for the first round of getting it fully sorted and drive-ability modifications in a couple weeks.
Till then, I have still been driving it like crazy - the smoking must have been from it sitting for a while cause that hasn't happened again, the heater core/seal does apparently need to be addressed cause it's not like there is a bunch of stuff dropping in, its still shiny on that rubber mat so there is still a little coming out.
Just to add to the list - the e-brake doesnt seem to work either.
Despite all that trivial stuff - I still love it :-)

Custom Auto also said that regardless of if the engine needed a rebuild or not, that they could modify it to handle unleaded fuel better than it will in stock form...so I'll definitely be getting that done. on that same note - there is a pump south of Loveland that has 93oct, so I took advantage of that on the way out too - this car sure is thirsty :-)

tbird430 02-22-2011 04:24 PM

Several companies actually make a lead additive for these old cars. STP is one that I still have lying around. I run the 93 octane in my 430cid too.

You really don't absolutely have to have the lead additive unless you are pulling something or really burning up the highway/interstate a lot. For these small leasure drive that you have made, you will be safe. ;)

-Jon in TX.

scumdog 02-22-2011 07:15 PM

Quote:

Originally Posted by tbird430 (Post 53311)
Several companies actually make a lead additive for these old cars. STP is one that I still have lying around. I run the 93 octane in my 430cid too.

You really don't absolutely have to have the lead additive unless you are pulling something or really burning up the highway/interstate a lot. For these small leasure drive that you have made, you will be safe. ;)

-Jon in TX.

Yup, haven't used any additive since lead went out here in Enn-Zee.

Maybe one day it might bite me on the arse (so to speak) but as of yet all is well.


I just make sure I run the highest octane I can buy - in this town it's 95 = to about 89 in the US.

In the city you can get 98 octane, my F100 runs way better on that.(11:1 429)

villain 02-23-2011 10:48 AM

Quote:

Originally Posted by scumdog (Post 53318)
Yup, haven't used any additive since lead went out here in Enn-Zee.

Maybe one day it might bite me on the arse (so to speak) but as of yet all is well.


I just make sure I run the highest octane I can buy - in this town it's 95 = to about 89 in the US.

In the city you can get 98 octane, my F100 runs way better on that.(11:1 429)

Hope all is well for you and family in NZ dude.

Dakota Boy 02-23-2011 11:06 PM

your experience so far seems alot like mine:

Get the car.

Make a list of everything you need/want to fix.

Then knock 'em off one by one....

Enjoy!

by the way, I got my clock to work with a little light oil... the original mechanism with all the tiny gears is SO cool. Made in Delavan, WI Dec 1957 stamped on the back. Good stuff!!!


All times are GMT -4. The time now is 12:59 AM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Any submissions to this site and any post on this site becomes property of Squarebirds.org . The webmasters reserve the right to edit and modify any submissions to this site. All material on this is site is copyrighted by the Squarebirds.org. Reproduction by any means other than for personal use is strictly prohibited. Permission to use material on this site can be obtained by contacting the webmasters. Copyright 2002-2016 by Squarebirds.org.