Announcement

Collapse
No announcement yet.

Fuel Pump?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Fuel cap

    Originally posted by simplyconnected View Post
    You don't have cavitation, or vapor lock. OEM fuel pumps are diaphragm-type so there is no high speed vanes or blades. We never heard a word about taking John's suggestion in regards to the tank cap.
    I did install a vented cap and had the same problem. (I also drilled a tiny hole in the [previously un-vented] locking cap to allow venting.)

    Originally posted by simplyconnected View Post
    Aside from all that, your car and millions of others worked perfectly fine from the factory and for many years.
    ...which makes it all the more irritating.

    Cheers,
    Richard, '66 Thunderbird Hardtop, 390FE, Edelbrock Al heads, Comp cam, Street Demon 650 carb. Visit my restoration blog at hwythunder.com.

    Comment


    • #32
      Originally posted by HighwayThunder View Post
      ...which makes it all the more irritating...
      If you know OEM parts work when fitted properly, the only thing left to do is proper troubleshooting and maintenance. This issue does not require re-engineering or parts that are different from 'stock'.

      Start troubleshooting by opening the fuel line and cranking the engine. If you get fuel, good. If not, check the pump and line back to the tank.
      My latest project:
      CLICK HERE to see my custom hydraulic roller 390 FE build.

      "We've got to pause and ask ourselves: How much clean air do we need?"
      --Lee Iacocca

      Comment


      • #33
        The Heat Goes On

        The vapor lock problem continues despite my measures taken to abate it. This is a summary of actions taken so far:
        • Made all fuel lines the same diameter tubing (3/8Ē)
        • Routed fuel lines above and away from the engine and insulated them
        • Installed a carburetor heat shield
        • Replaced the 195F thermostat with a 160F thermostat
        • Replaced the mechanical fan with a shrouded electric fan
        I think itís safe to assume that the continuing problem is still related to heat, with pressure and fuel flow rate assisting factors. With that in mind, there are two solutions that may alleviate the vapor lock.
        • During idle, fuel is not moving quickly through the lines nearest the engine, giving the fuel time to absorb heat. My electric fuel pump does not have a return line to the fuel tank. Putting an overpressure regulator near the carburetor with a return line back to the tank would allow fuel to flow at a near constant rate, reducing the amount of heat absorption in the line.
        • The PCV valve is connected via the carburetor rather than the intake manifold. I suppose itís possible that the carb is pulling heat in through that connection. I plan to reroute the PCV to the intake manifold as a precaution.
        Comments appreciated.


        Cheers,
        Richard, '66 Thunderbird Hardtop, 390FE, Edelbrock Al heads, Comp cam, Street Demon 650 carb. Visit my restoration blog at hwythunder.com.

        Comment


        • #34
          All your changes are wonderful but NONE of them address the real problem which is, 'why isn't gas getting to the carb?'

          You can prove your system very simply and in the comfort of your own garage. Invert a hanging soda-pop bottle filled with gasoline and vented, with a temporary rubber hose connected to your carb's inlet. Gravity feed works just fine, especially when the engine is not under load. You can still rev, which makes your mechanical fuel pump go faster.

          The disconnected fuel line you removed simply goes into a gallon gas can. It's ok to extend the original line so the gallon container can sit on the ground because there is zero flow resistance at the end of that open hose.

          Start your engine and watch. Even at idle speeds, flow shouldn't take long to fill a gallon container. When you rev the engine the container will fill faster with a mechanical pump but your electric pump will be steady. Tell us how long it takes your pump to fill a gallon container.

          This test removes all possibility of heat-related and it reveals pressure-related issues. You should see gas gushing out. If you don't, test for restrictions, in small steps, all the way back to your fuel tank. From here in Michigan, I cannot tell if you have a hose that has collapsed from the inside or a fuel tank pickup that is clogged. YOU have to find those issues by employing sound troubleshooting techniques instead of throwing parts at a problem. We already know that working 'factory' systems performed well on many thousands of Thunderbirds like yours. - Dave
          My latest project:
          CLICK HERE to see my custom hydraulic roller 390 FE build.

          "We've got to pause and ask ourselves: How much clean air do we need?"
          --Lee Iacocca

          Comment


          • #35
            Gas gets to the carb just fine while the car is warming up. It is after idling at temp for about 20 minutes that it stalls. The car did that with the old mechanical fuel pump and it does it with the new electric fuel pump. So I think I've eliminated the fuel pump as the culprit. I've replaced most of the fuel lines (but as stated, gas gets to the carb just fine while the car is warming up, so no kinks or restrictions in the lines).

            What's left is a correlation with increasing heat.

            Outside of the fuel system, a possible cause could be temperature-sensitive ignition components.

            Cheers,
            Richard, '66 Thunderbird Hardtop, 390FE, Edelbrock Al heads, Comp cam, Street Demon 650 carb. Visit my restoration blog at hwythunder.com.

            Comment


            • #36
              I agree that high temps can have an affect on your ignition coil BUT fuel delivery and ignition are totally separate issues that can be proved independently.

              I'm still not convinced you have a vapor lock problem because it is rare, moving fuel under positive pressure would need a lot of heat (that we don't have) and your carb has floats that open until liquid fuel closes them. Otherwise, the float bowls are vented to your engine-side of the carb.

              I thought we were addressing this issue:



              Now you say, it's getting gas. Is it or not? Idle speeds do not drink much gas. When this fault shows up, can you pump the throttle while watching for a squirt of gas? No, you don't need to stick your face over the carb if you use a mirror and a light. If you see squirts of gas, you don't have a fuel problem.

              If you think your coil is causing problems, while the problem occurs pull a spark plug wire and plug it into a spare spark plug, laying on the intake manifold. It's better if you do this at dusk and outside. What does the spark look like? Do you hear it 'snap'? Is it pretty blue, or orange? If it's orange, temporarily swap with another car's coil. I don't care if the temporary coil is for a six cylinder, it should work. Are you still using a condenser, and is your points plate grounded? - Dave
              My latest project:
              CLICK HERE to see my custom hydraulic roller 390 FE build.

              "We've got to pause and ask ourselves: How much clean air do we need?"
              --Lee Iacocca

              Comment


              • #37
                Hallelujah

                I think the epic saga of the stalling car has finally come to a finale.

                Yesterday I rerouted the PCV line from the carb to the intake maniifold.

                I also moved the the heater hose from a place where it was touching the fuel line near the carb (see photo). Later on that day I visited a car show (every second Saturday in Tucker, GA main square). A teenager restoring a 66 Mustang said he'd had the same problem with vapor lock and had traced it to the fuel line in contact with the heater hose. (!)

                This morning when I tested the T-bird the problem seems to have gone. It ran for about 20 minutes without stalling. Temp stabilized at about 190F. Turned the car off. About 8 minutes later the engine restarted. Ran steadily at idle speed with no power loss.

                I'm so thrilled to be able to drive the car without fear of being stranded and towed.

                I hope this thread will be of benefit to anyone dealing with a similar enigma.

                Thanks to all of you for being part of the process. This forum is a fabulous resource. I only hope that I can contribute in kind.

                Cheers,
                Attached Files
                Richard, '66 Thunderbird Hardtop, 390FE, Edelbrock Al heads, Comp cam, Street Demon 650 carb. Visit my restoration blog at hwythunder.com.

                Comment

                Working...
                X