Announcement

Collapse
No announcement yet.

My '66 Hardtop Town Build

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Changed my stabilizer bar end links today while I had the car jacked up to service the front wheel bearings, cleaned and repacked the drivers side with no issue. the inside passenger side bearing sounded link a glass jar full of nails when I shook it, upon the advice of my FIL I had my wife pickup a new bearing on the way home from work. hope to get it installed 2moro morning and get a test drive in before my helper needs a nap and I have to go to work.

    Still lots to learn about cars but another two successfull first attempts today
    2016 FORD F150 XLT 3.5 EB SPORT 302a - 2012 KAWASAKI ZX-6R - 2012 LEGEND DELUXE V-NOSE - 2008 KAWASAKI ZZR600 - 2008 FORD FOCUS SE - 2007 KAWASAKI ZX-6R - 2002 ARTIC CAT 500 - 1990 JOHN DEERE 265 - 1966 FORD THUNDERBIRD HARDTOP TOWN

    Comment


    • here is a album i keep updated with photos

      https://www.facebook.com/media/set/?...1&l=ccb39d4f6a
      2016 FORD F150 XLT 3.5 EB SPORT 302a - 2012 KAWASAKI ZX-6R - 2012 LEGEND DELUXE V-NOSE - 2008 KAWASAKI ZZR600 - 2008 FORD FOCUS SE - 2007 KAWASAKI ZX-6R - 2002 ARTIC CAT 500 - 1990 JOHN DEERE 265 - 1966 FORD THUNDERBIRD HARDTOP TOWN

      Comment


      • Grr noise is still there after a test drive, I can hear it above 45mph durring acceleration or cruising, but not deceleration.

        My friend suggested checking the drive shaft and trans mount, and after some googling now I'm wondering maybe its the front end alignment I know we need one. Her dad also suggested to check the tie rod ends. Anyone have other suggestions?
        Last edited by Cwcb08; August 18th, 2017, 09:58 PM.
        2016 FORD F150 XLT 3.5 EB SPORT 302a - 2012 KAWASAKI ZX-6R - 2012 LEGEND DELUXE V-NOSE - 2008 KAWASAKI ZZR600 - 2008 FORD FOCUS SE - 2007 KAWASAKI ZX-6R - 2002 ARTIC CAT 500 - 1990 JOHN DEERE 265 - 1966 FORD THUNDERBIRD HARDTOP TOWN

        Comment


        • Thanks Cody for the pics . always great to see what I may be seeing when I tear things apart on my 66. :-)

          Faron

          Comment


          • Originally posted by FARONZ 66 Q CODE View Post
            Thanks Cody for the pics . always great to see what I may be seeing when I tear things apart on my 66. :-)

            Faron
            Hopefully they help you Faron, pictures always help me




            Going to try and rwplace the trans mount today, after jacking gently on the tail shaft it looks like the rubber and steel have separated
            Last edited by Cwcb08; August 23rd, 2017, 12:10 AM.
            2016 FORD F150 XLT 3.5 EB SPORT 302a - 2012 KAWASAKI ZX-6R - 2012 LEGEND DELUXE V-NOSE - 2008 KAWASAKI ZZR600 - 2008 FORD FOCUS SE - 2007 KAWASAKI ZX-6R - 2002 ARTIC CAT 500 - 1990 JOHN DEERE 265 - 1966 FORD THUNDERBIRD HARDTOP TOWN

            Comment


            • Frustrating day, carquest didn't call all week so I called them and the mount was in, awesome, had my wife pick it up on the way home from work.

              Go to install it after spending 45min trying to get the 3 mount bolts out and the 2 crossmember bolts out around the exhaust and its not the right mount!
              Must be the cruise-o-matic mount, our car has a c6.

              The holes in the mount are about 3/4" to far apart, will take the new mount back and try and get the correct one ordered locally
              2016 FORD F150 XLT 3.5 EB SPORT 302a - 2012 KAWASAKI ZX-6R - 2012 LEGEND DELUXE V-NOSE - 2008 KAWASAKI ZZR600 - 2008 FORD FOCUS SE - 2007 KAWASAKI ZX-6R - 2002 ARTIC CAT 500 - 1990 JOHN DEERE 265 - 1966 FORD THUNDERBIRD HARDTOP TOWN

              Comment


              • Most auto stores only show the COM motor mount. Even Rockauto doesn't show the correct C6 mount. You may have to order it from one of the Thunderbird vendors like Mac's. They have the correct one in stock.

                John
                John Pizzi - Squarebirds Administrator

                Thunderbird Registry #36223
                jopizz@verizon.net 856-779-9695

                http://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

                Comment


                • Originally posted by jopizz View Post
                  Most auto stores only show the COM motor mount. Even Rockauto doesn't show the correct C6 mount. You may have to order it from one of the Thunderbird vendors like Mac's. They have the correct one in stock.

                  John
                  thats a bummer, i hate waiting for parts!

                  car quest couldn't even cross reference the c6 mount part number, looks like i will have to order online. so far macs has the best price at $15.49
                  2016 FORD F150 XLT 3.5 EB SPORT 302a - 2012 KAWASAKI ZX-6R - 2012 LEGEND DELUXE V-NOSE - 2008 KAWASAKI ZZR600 - 2008 FORD FOCUS SE - 2007 KAWASAKI ZX-6R - 2002 ARTIC CAT 500 - 1990 JOHN DEERE 265 - 1966 FORD THUNDERBIRD HARDTOP TOWN

                  Comment


                  • The mounts look identical except for the hole spacing. I imagine you could elongate the holes in the COM mount to fit the C6 if you don't want to wait.

                    John
                    John Pizzi - Squarebirds Administrator

                    Thunderbird Registry #36223
                    jopizz@verizon.net 856-779-9695

                    http://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

                    Comment


                    • That might have worked but if it didn't I would be out the 15$ and still have to buy the right one.

                      I ordered from macs this morning and got an email it was shipped this afternoon.
                      2016 FORD F150 XLT 3.5 EB SPORT 302a - 2012 KAWASAKI ZX-6R - 2012 LEGEND DELUXE V-NOSE - 2008 KAWASAKI ZZR600 - 2008 FORD FOCUS SE - 2007 KAWASAKI ZX-6R - 2002 ARTIC CAT 500 - 1990 JOHN DEERE 265 - 1966 FORD THUNDERBIRD HARDTOP TOWN

                      Comment


                      • YAY, the grinding noise is gone!

                        Went across the border this morning and picked up the mount installed it then went for a test drive.

                        More good news now I can feel the car shift twice while driving vs just once.

                        Tested my fuel gauge and sending unit again as well, grounding the gauge pegs the needle full but I get no resistance when I test the sending unit. Can it be serviced or will it have to be replaced. Who has the best price and quality unit if its not serviceable? My car has the low fuel light. Will that work with a bad unit or are they tied together?
                        2016 FORD F150 XLT 3.5 EB SPORT 302a - 2012 KAWASAKI ZX-6R - 2012 LEGEND DELUXE V-NOSE - 2008 KAWASAKI ZZR600 - 2008 FORD FOCUS SE - 2007 KAWASAKI ZX-6R - 2002 ARTIC CAT 500 - 1990 JOHN DEERE 265 - 1966 FORD THUNDERBIRD HARDTOP TOWN

                        Comment


                        • My '66 Hardtop Town Build

                          Cody, I would suggest that you check with the various Tbird parts houses listed in the Advertisements Forum. I can tell you this though. The Bird Nest in Oregon rebuilds these gauges like new again. They have rebuilt mine in the past and do great work. I would suggest emailing or calling them, give them an overview of the problem and get a quote from them. Or check the For Sale Forum, if you have not already done so, to see if someone is parting out a '66 Tbird. If so, perhaps you can get a working gauge from them.

                          Ray Clark - Squarebirds Administrator
                          '59 Tbird "The Yellow Rose Of Texas" aka "Tweety Bird"
                          "It's Hip To Be Square"
                          Thunderbird Registry #33025 VTCI #11178

                          Contact me via Private Message for my email address, or (Cell) 210-875-1411 (Home) 210-674-5781

                          http://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

                          Comment


                          • Thanks for the reply Ray but it looks like you misread my post, the gauge functions correctly ( ground it= reads full, remove ground = goes back to empty ). Its the sending unit that does not function.
                            2016 FORD F150 XLT 3.5 EB SPORT 302a - 2012 KAWASAKI ZX-6R - 2012 LEGEND DELUXE V-NOSE - 2008 KAWASAKI ZZR600 - 2008 FORD FOCUS SE - 2007 KAWASAKI ZX-6R - 2002 ARTIC CAT 500 - 1990 JOHN DEERE 265 - 1966 FORD THUNDERBIRD HARDTOP TOWN

                            Comment


                            • You can try and take the sender apart. Normally it's rust and scale from gasoline seeping inside that causes it not to work. I've had some degree of success. If the parts are still intact when you take the small cover off you can probably fix it. If the parts have deteriorated you will need a new sender. There are two different fuel senders; one with low fuel warning and one without.

                              John
                              John Pizzi - Squarebirds Administrator

                              Thunderbird Registry #36223
                              jopizz@verizon.net 856-779-9695

                              http://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

                              Comment


                              • My '66 Hardtop Town Build

                                Sorry, Cody, I would think that if you cant fix the sending unit, that one of the Tbird parts houses would have one. Or someone parting out a '66 Tbird...

                                Ray Clark - Squarebirds Administrator
                                '59 Tbird "The Yellow Rose Of Texas" aka "Tweety Bird"
                                "It's Hip To Be Square"
                                Thunderbird Registry #33025 VTCI #11178

                                Contact me via Private Message for my email address, or (Cell) 210-875-1411 (Home) 210-674-5781

                                http://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

                                Comment

                                Working...
                                X