Announcement

Collapse
No announcement yet.

Fuel pump

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fuel pump

    Hi guys,
    Iīm not sure if I have a problem or not...
    My car drives quite OK, but sometimes when Iīm just cruisin in low speed for a while, and just want to accelerate firm, she kind of "hick" first before she sets off. Nearly dies. Feels a bit embarrasment to be honest. So I installed connectors for Lambda sond on the exhaust near the manifold so we can measure if ( and where ) she is rich or/and lean. Ordered a carburator calibration kit and played around with springs and needles and mesure the difference all the time. My engine is now pretty much perfect in all idle, acceleration or cruise mode.
    But: When the engine is on, and regardless of idle or playing with the throttle, I can see that there is very little fuel in my fuel filter. Looks nearly empty as a matter of fact.
    Can this be due to some problem with the Fuel Pump? Should I buy a new one or check anything else? Any help here is much appreciated. Please have in mind that my engine is a 1964 390.
    sigpic..."Lil darling Ruth"
    http://www.tbirdregistry.com/#33158

  • #2
    Anders, I don't know if your fuel delivery is right or not but I would NOT use a filter level as a gauge.

    Carbs use very low fuel pressure and they regulate their reservoir level with a float. THAT's the real gauge. I would suggest, if you floor your gas on a fast road for a good amount of time and it never runs out of gas, the fuel pump and filter are probably ok. Try this climbing a mountain, too.

    Do not discount your distributor timing. There are springs in the centrifugal advance that 'take over' from your vacuum advance, back and forth with the gas pedal. Make sure your vacuum advance unit is working and connected to the proper inlet port. Many vacuum units have a hex key adjustment screw inside the inlet port. They are notorious for failing after many years. This is covered in your Shop Manual, and it really doesn't matter which FE engine you are running. - Dave
    My latest project:
    CLICK HERE to see my custom hydraulic roller 390 FE build.

    "We've got to pause and ask ourselves: How much clean air do we need?"
    --Lee Iacocca

    Comment


    • #3
      Originally posted by simplyconnected View Post
      Anders, I don't know if your fuel delivery is right or not but I would NOT use a filter level as a gauge.

      Carbs use very low fuel pressure and they regulate their reservoir level with a float. THAT's the real gauge. I would suggest, if you floor your gas on a fast road for a good amount of time and it never runs out of gas, the fuel pump and filter are probably ok. Try this climbing a mountain, too.

      Do not discount your distributor timing. There are springs in the centrifugal advance that 'take over' from your vacuum advance, back and forth with the gas pedal. Make sure your vacuum advance unit is working and connected to the proper inlet port. Many vacuum units have a hex key adjustment screw inside the inlet port. They are notorious for failing after many years. This is covered in your Shop Manual, and it really doesn't matter which FE engine you are running. - Dave
      Thankīs Dave. No, there is no problem accelerating up to 70 mph ( donīt dare to go much faster with this old babe ) or in uphill. My only small problem, because we are into real finetuning, is a little reaction, like a delay ( goes lean ) for a millisec when I am going cruice for some time and then just hammer the throttle. My friend also mensioned some springs or parts for the distributor. I have MSD Ignition. Do you know what springs could help?
      sigpic..."Lil darling Ruth"
      http://www.tbirdregistry.com/#33158

      Comment


      • #4
        It could also be carburetor related. Possibly a worn or misadjusted accelerator pump or pump linkage or your floats might be set too low.

        John
        John Pizzi - Squarebirds Administrator

        Thunderbird Registry #36223
        jopizz@verizon.net 856-779-9695

        http://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

        Comment


        • #5
          New discoverys..... My fuel pump is leaking and I need a new one.
          Ordered one for a 1964 390 ( B 9350A ) only to see that it wasnīt any vacum model...
          So, If any of you can identify the one I have ( original ? It does not have the mentioned "with Glass Bowl" listed for 58/60....) and/or guide me what type I shall buy, it would be very helpful. I have another question as well. On top of mine, there is two connectors for Vacum. Funny enough, the only one that is conected anywhere is the one with the bit of hose left on it. The other one was blocked. There is a text on the part showing that this one is for the Vipers. My Viper is connected to a 3-way conector on the manifold. But my Vipers are quite poor in performance as they only works when I donīt accelerate.. Would the function be better if I relocate the hose for the Viper to this location? It sounds like it should...
          Attached Files
          sigpic..."Lil darling Ruth"
          http://www.tbirdregistry.com/#33158

          Comment


          • #6
            The correct pump for your '58 would be a 9350D. Dual action with the glass bowl. The vacuum from the fuel pump to the wipers is supposed to be an improvement over regular manifold vacuum. It still won't be perfect compared to today's wipers but I would hook it up correctly and see if you get any improvement.

            John
            John Pizzi - Squarebirds Administrator

            Thunderbird Registry #36223
            jopizz@verizon.net 856-779-9695

            http://www.squarebirds.org/picture_gallery/TechnicalResourceLibrary/trl.htm

            Comment


            • #7
              Originally posted by jopizz View Post
              The correct pump for your '58 would be a 9350D. Dual action with the glass bowl. The vacuum from the fuel pump to the wipers is supposed to be an improvement over regular manifold vacuum. It still won't be perfect compared to today's wipers but I would hook it up correctly and see if you get any improvement.

              John
              Thanks! So there will not be any problem to connect this "58/60 Dual action with glass bowl" to a 1964 390 Engine?
              sigpic..."Lil darling Ruth"
              http://www.tbirdregistry.com/#33158

              Comment


              • #8
                Nope...
                sigpic
                The 1960 Ford Thunderbird. The WORLD'S most wanted car....

                VTCI Member#6287.

                Comment


                • #9
                  Thanks guys!
                  sigpic..."Lil darling Ruth"
                  http://www.tbirdregistry.com/#33158

                  Comment

                  Working...
                  X