PDA

View Full Version : Transmission problem


jack&chris
08-15-2017, 11:29 AM
We had the transmission and torque convertor rebuilt now we are having a problem it chatters in park and neutral and will not shift in drive it just stays in low. Anyone have any ideas how to solve these problems

jopizz
08-15-2017, 11:48 AM
We had the transmission and torque convertor rebuilt now we are having a problem it chatters in park and neutral and will not shift in drive it just stays in low. Anyone have any ideas how to solve these problems

Did you get a warranty when you had it rebuilt? It could be just the linkage being out of adjustment but whoever rebuilt it should've adjusted it when you had it done so the car was driveable.

John

jack&chris
08-15-2017, 12:20 PM
we are installing the transmission but the man who rebuilt it is trying to help us out. We will try reset the linkage. Thank you for your help

jopizz
08-15-2017, 12:59 PM
In addition to the linkage I would check the obvious. Make sure you have the correct fluid and it's at the right level. Make sure the modulator has good vacuum and is not leaking.

John

jack&chris
08-15-2017, 01:23 PM
Thanks Joe, the man that rebuilt the transmission told us to adjust the linkage in the neutral position, when I went to the shop manual that I downloaded it said to do it in D2. We did that and all of the chattering is gone. Also the vacuum line was not connected good and it is now shifting properly. We are at the point now we just have some little things to do and she is ready to hit the road.
Thank you for your help.
Chris

jopizz
08-15-2017, 03:02 PM
Thanks Joe, the man that rebuilt the transmission told us to adjust the linkage in the neutral position, when I went to the shop manual that I downloaded it said to do it in D2. We did that and all of the chattering is gone. Also the vacuum line was not connected good and it is now shifting properly. We are at the point now we just have some little things to do and she is ready to hit the road.
Thank you for your help.
Chris

Chris,

You're welcome. I'm glad to see that it only needed a couple of easy fixes and you are close to getting her back on the road.

John